Sonntag, 23. Mai 2010

Mac OS X unter Windows 7 mit Virtualbox 3.2.0

Da in den letzten Tagen die neue Version von Virtualbox erschienen ist, dachte ich mir es wäre nun mal an der Zeit ein How-To abzubilden, wie man sehr leicht unter Virtualbox ein Mac OS X Snow Leopard ans Laufen bekommt. Alles was man dazu braucht ist

1) eine Snow Leopard Retail DVD, die es für etwas über 20 Euro bei Amazon gibt. (oder Ihr leiht Euch von einem Freund einfach die DVD und macht ein ISO davon)
2) ein EmpireEFI ISO (ich benutze empireEFIv1085.iso) gibt es unter http://prasys.co.cc/osx86hackint0sh/ zum Download
3) und natürlich Virtualbox Version 3.2.0 Download unter http://www.virtualbox.org/

Das wars.

Nach der Installation von Virtualbox legt man sich einfach eine neue VM an:

Man vergibt einen Namen für die VM und wählt als BS und Version einfach Mac OS X aus

gibt der VM etwas Speicher (1024 MB, oder besser 2048 MB)

legt eine neue virtuelle Festplatte an:


vergibt einen Namen und eine Grösse:

und fertig ist die VM angelegt:

Anschließend nochmals mit Ändern die VM Eigenschaften bearbeiten:

Die Boot-Reihenfolge auf zuerst CD/DVD und dann Platte festlegen (Diskette deaktivieren) und WICHTIG! erstmal EFI deaktivieren (wird erst später aktiviert)

die Anzahl CPU´s festlegen, kann man mit 1 CPU oder entsprechend 2 oder 4 - je nachdem was Eure CPU hergibt ;-) - ich benutze erstmal nur eine CPU:

der Rest kann im SYSTEM Bereich so bleiben:



Unter Anzeige den Grafikspeicher auf max 128 erhöhen, und die 3D-Beschleunigung aktivieren:

Unter Plattenspeicher als "Storage Controller" darauf achten das ICH6 ausgewählt ist:
und passend dazu unter dem CD Laufwerk das empireEFIv1085.iso auswählen:

Das wars. Danach die VM starten und es erscheint der Empire EFI Boot-Screen

Nun über das Virtualbox Menü unter Geräte die CD auswerfen:





und entsprechend das ISO-Image der Original "Mac OS X Snow Leopard" DVD auswählen. (Zum erstellen von ISO-Images benutze ich immer ImgBurn, der ist schnell, klein und for free)

Anschließend einen Augenblick warten bis Virtualbox das neue ISO an die VM übergeben hat, und danach F5 drücken. Nun seht Ihr das das Empire EFI die Mac OS X DVD erkannt hat. Mit Enter bestätigen:

und es wird vom ISO-Image weitergeladen:

Nach einer kurzen Weile erscheint der Mac OS X Screen und fragt Euch nach der Installations-Sprache:

Nach Auswahl der Sprache:

müsst Ihr unter Dienstprogramme das "Festplatten-Dienstprogramm" starten:

Hier auf dem Reiter "Partition" mit dem + Button eine neue Partition anlegen, einen Namen vergeben und mit Anwenden die Partition erstellen:

Danach das Festplatten-Dienstprogramm beenden:

Nun wird die neue Partition als auswählbar angzeigt:

Mit dem Button Anpassen (unten links) kann man etwas Festplattenplatz sparen indem man z.B. bei Sprachpakete alles bis auf die Wunschsprache abwählt:

Nun Installieren:
und nach ca. 20 Minuten ist die Installation beendet:

Danach einen Neustart. Dieser wird irgendwie wie folgt "hängenbleiben". Das ist aber kein Problem, einfach über Virtualbox die VM einfach ausschalten:

Da wir im vorherigen Boot-Vorgang das Mac OS X ISO gemountet haben, stimmen nun einige Parameter nicht mehr, d.h. diese anschließend nochmals mit Ändern in die VM korrigiern, und wie gehabt unter System die Boot-Reihenfolge auf DVD und dann Platte einstellen, und unter Plattenspeicher das empireEFIv1085.iso auswählen (so wie vorher beschrieben). Danach die VM starten. Nun erscheint neben dem EVI-Image auch noch Mac OS X. Dieses auswählen und mit Enter starten:

Anschließend erscheint der Mac Willkommen-Screen. Hier die entsprechenen Angaben bestätigen:

Tastatur auswählen:

und einen lokalen Benutzer anlegen. Merkt Euch bitte den Login und das Passwort welches Ihr eingebt, da das Passwort unter Anderem bei nachfolgenden Programm-Installationen erneut eingegeben werden muss:

Zeitzone ausählen:

und ein "Vielen Dank":

Anschließend erscheint der Mac Desktop:

Nun mittels Safari kurz prüfen, ob die Internet-Verbindung geht:

Das wars. Nun habt Ihr ein Mac OS X unter Virtualbox installiert.

Wer nun in der Anleitung weitermachen möchte, kann dies machen, ist aber kein Muss. Jetzt kommt nur noch der Part das wir das Empire-ISO welches wir als "Starthilfe" benutzen deaktivieren können.

Dazu müsst Ihr einen Satz Kexts File von
http://www.taranfx.com/how-to-install-mac-os-x-snow-leopard-on-pc-dual-boot
downloaden. Einfach die Seite nach dem String Kext absuchen. Es gibt hier einen MediaFire und Rapidshare Download. Da Ihr die Files in Eurer VM benötigt, ladet diese am Besten dort herunter, dann spart Ihr Euch das Übertragen der File von Windows nach Mac OS X. Für die Kext-Files braucht Ihr noch einen Editor den "Kext Helber" (Google ist Euer Freund). Diesen könnte Ihr z.B. von http://cheetha.net/ downloaden.

Dann den Kext Helper starten und die beden Kext-Files NullCPUPowerManagement.kext und fakesmc.kext per Drag and Drop auf den Kext Helper ziehen, Euer Password eingeben und auf Easy Install drücken:
Nach der Installation Mac OS X beenden. Das wird nicht komplett gehen, und es bleibt ein Crash-Screen übrig. Hier aber einfach die VM ausschalten:

Anschließend mit Ändern der VM die Boot-Reihenfolge auf Platte und dann DVD ändern, und WICHTIG "EFI aktivieren".

Nun die VM neu starten. Hier ab diesem Punkt gab es bei mir ein paar "Ungereimtheiten", d.h. beim ersten Booten der VM blieb der Screen beim Booten hängen, und ich sah den Mac Desktop nicht. Hier habe ich dann einfach die VM ausgeschalten und erneut gestartet, und danach liefs dann wieder. Naja komisch ?!

Was weiterhin nicht geht ist das "Herunterfahren". Hier bleibt immer noch ein Crash-Screen übrig. Aber das ist kein Problem, hier dann einfach die VM über Virtualbox ausschalten.

Anschließend könnt Ihr je nach Lust und Laune ein paar Programme ausprobieren, evtl. ein Office installieren (ich hatte zufällig eine Trial-Version von Microsoft Office 2008 for Mac hier)

und vielleicht mal Word in einem ganz anderen Design erleben:


Anschließend mach ich mir immer von der entsprechenden Virtualbox Harddisk (VDI) eine Kopie, um meine Arbeit zu sichern, damit ich bei einem Zerstören der Installation wieder nicht bei Null beginnen muss.
Trotz Alledem, ist das Ganze noch nicht ganz ausgereift, da ich ab und an 2-3 mal die Mac OS X VM booten muss, bis ich endlich den Desktop zu Gesicht bekomme, bzw. auch schon mal erlebt habe, dass ich wieder das Empire EFI ISO zum Starten (ohne EFI-aktivieren in der VM) einbinden muss.
Naja, aber trotzdem finde ich, ist der Weg richtig, und über Kurz&Lang funktioniert das sicher bald genauso gut, wie ein XP in der VM.

Wenn ich Mac OS X in der VM laufen lasse, merke ich jedoch die deutlich höhere CPU-Auslastung als bei einer normalen "Windows VM", zumindest auf meiner mittlerweile betagten Core2Duo CPU (wann kommt denn mein i7 ?!)

Kommentare:

  1. Glückwunsch zum iPad :)
    Ne Idee, ob es möglich ist bei MacOs unter VirtualBox die Auflösung höher als 1024x768 zu stellen ?

    AntwortenLöschen
  2. Danke für das Tutorial ;)
    Echt gut erklärt.

    AntwortenLöschen
  3. Hey, tolle anleitung, leider klappt bei mir das booten mit empireEFI_v1085 nicht.

    in meiner iso sind 3 ordner (Extra, Post-Installation, usr)

    komme nachdem ich das iso boote immer in eine EFI Shell version 2.10

    mach ich was falsch? ;)

    AntwortenLöschen
  4. und WICHTIG! erstmal EFI deaktivieren (wird erst später aktiviert)


    das....

    AntwortenLöschen
  5. Kann das sein, dass es nicht funktioniert, wenn der Wirt eine AMD CPU hat?

    AntwortenLöschen
  6. Klasse Tut !

    Aber bei mir funktioniert der letzte Teil nicht wo man die "Empire-Iso" abschalten kann. Sobald ich das mit dem helper gemacht und anhand Deiner Anleitung gemacht habe, hängt sich jedesmal die Virtualbox (Oracle 3.2.4) weg. Dies lässt sich bei mir wieder nur beheben, wenn ich die Empire-Iso wieder dazwischen hänge und davon booten lasse.
    Gibts da evtl. ein anderes Tut, bzw. ein Update zu ?

    AntwortenLöschen
  7. Gibt es eine Möglichkeit eine höhere Auflösung als 1024x768 einzustellen?. Mit den GuestAdditions klappt es nicht, da hier keine für Mac OS X Systeme vorhanden sind.

    AntwortenLöschen
  8. Hallo,

    ich verwende empireEFIv1085.iso mit Mac OSX 10.6.3 (Update DVD) auf Virtual Box 3.2.6 r63112.

    Hardware ist ein Core i5-670, 8GB RAM und es wird die Grafikkarte aus dem Corei5 verwendet. Die Virtuelle Maschine hat 4 GB RAM zugeordnet.

    Leider scheint das nicht zu funktionieren. EFI ist ausgeschaltet und ICH6 ist aktiviert. Was kann das Problem sein? Ist evtl die Mac OSX Version zu neu?

    AntwortenLöschen
  9. ich denke Virtual Box 3.2.6 und Mac OSX 10.6.3 sind sicher ok, da sehe ich nicht das Problem. An welcher Stelle im Bootvorgang bleibt das empireEFIv1085.iso denn hängen ?

    empireEFIv1085.iso ist ja quasi nur der Steigbügel umd anschließend Mac OS X zu starten.

    AntwortenLöschen
  10. Bzgl. Auflösung. Mit der eingestellten 1024x768 Auflösung kann man wirklich nicht so viel anfangen. Lt. Virtualbox Handbuch gibt es evtl. die Option das zumindest auf 1440x900 umstellen (hab ich aber noch nicht ausprobiert)

    http://www.virtualbox.org/manual/ch03.html#efividmode

    AntwortenLöschen
  11. >An welcher Stelle im Bootvorgang >bleibt das empireEFIv1085.iso denn >hängen ?
    >empireEFIv1085.iso ist ja quasi nur >der Steigbügel umd anschließend Mac >OS X zu starten.

    empireEFI startet allerdings wenn ich das image wechsele passiert nix.
    ich habe das ding mit poweriso erzeugt.(UDF)

    AntwortenLöschen
  12. mich würde interessieren bei wem es geklappt hat und welche windowsversion benutzt wure. bei mir wehrt sich der installationsdialog von os x 10.6 und meint, das eine installation auf dem system nicht möglich sei...

    AntwortenLöschen
  13. Zwecks "empireEFI startet allerdings wenn ich das image wechsele passiert nix.
    ich habe das ding mit poweriso.."
    ==> das sollte nicht unbedingt das Problem sein, ob jetzt Poweriso oder IMGBurn, sollte egal sein. Damit Ihr sicher seid, dass Ihr ein gutes Mac OS X Image habt, und das nicht aus einer dubiosen Torrent-Quelle kommt, würde ich wirklich 20 Euro für eine Orignal-Mac OS X 10.6 DVD ausgeben und dann davon ein Image machen. Beim Wechsel des Image über die Virtualbox Menüleiste, würde ich einfach nachdem das ISO von Mac OS X eingelegt wurde, ein paar Sekunden warten, bevor man die Auswahl mit ENTER abschickt, nur um sicherzustellen, dass das Image korrekt an das Guest-OS weitergegeben wurde.

    AntwortenLöschen
  14. Bzgl. Windows-Version und bei wem die Installation geklappt hat. Ich hab den Install mittlerweile auf zwei anderen Rechnern durchgeführt, lief tadellos. Das waren alles ausnahmslos Intel Core2Duo Maschinen. Vermutlich läuft das nicht auf AMD, da Apple (bis jetzt) auch nur Intel CPU´s verwendet. Betriebssystem ware immer Windows 7 sowohl in 32Bit als auch 64Bit, das macht keinen Unterschied (höchstens darin, dass man unter einem 32Bit Win7 dem Guest-Mac OS X nicht soviel Speicher zur Verfügung stellen kann).

    Wenn Du bis zum Mac OS X Dialog kommst, und hier die Info kommt dass eine Installation auf dem System nicht möglich ist, würde mich Deine Hardware und Dein Wirts-OS interessieren. Ich tippe hier wirklich auf eine Hardware-Unverträglichkeit in der Form dass es eine AMD-CPU ist, oder Ähnliches.

    Poste doch kurz Deine Hardwareconfig.

    AntwortenLöschen
  15. Hallo,
    Ich finde dein Tutorial super klasse, da ich Windows 7 besitze und Snow Leopard installieren möchte. Nun meine Frage, ist es egal dass ich einen AMD Prozessor und eine ATI Grafikkarte habe. Ist ja eigentlich nur eine Virtual Maschine. Desweiteren würde mich interessieren, ob ich dieses snow leopard in der virtual maschine auch seamless und im fullscreen booten lassen kann. D.h. ich möchte wenn ich meinen Computer anschalte direkt zu Mac os x snow leopard gelangen. Ist dies möglich ?

    MfG

    AntwortenLöschen
  16. Bzgl. einer AMD-CPU, da fehlen mir die Möglichkeiten weil ich keine AMD-CPU im Zugriff habe, ich kaufe immer nur Intel. Da Apple jedoch (bis jetzt) keine AMD-CPU´s für deren Produkte anbietet würde ich ein klares NEIN sagen, wenn es darum geht, ob mit einer AMD-CPU unter Virtualbox ein MAC OS X laufen kann. ATI-Grafikkarten sollten jedoch gehen, da Apple auch ATI-Karten verwendet.

    Zum Punkt "seamless und im fullscreen booten" - auch hier ein klares Nein! - Wer seinen PC so umbauen möchte, das sofort ein MAC OS X nativ gebootet wird, dem kann ich (derzeit) nur empfehlen auch einen echen Mac zu kaufen.

    AntwortenLöschen
  17. Sehr gutes Tutorial
    Aber ich habe eine Frage:
    Ich komme bis zum "Apfel-Screen"(der silberne Bildschirm mit dem Apple Logo)
    Und dann sagt mir Virtual Box das ein schwerwiegender Fehler aufgetreten ist und die Maschine muss beendet werden.
    Warum?
    Ich habe einen Intel Pentium 4 mit 3,20Ghz, der unterstützt nicht die Virtualisierungstechnologie aber Hyperthreading
    Außerdem brucht man die für Virtual Box mit OsX doch auch garnicht oder?
    Außerdem habe ich 2gb Ram und ne Ati Radeon Grafikkarte.
    Vielleicht kann mir jemand sagen warum es nicht funktioniert?
    Nils

    AntwortenLöschen
  18. Hört sich gut an, aber wenn ich das Mac-Iso einlege und dann F5 drücke kommt folgende Fehlermeldung:
    Memory allocation error (0xdaa2680, 0x20498)

    Was mache ich falsch? Ich benutze einen Intel Core i5-750 Prozessor und eine NVidia Geforce GTS240 Grafikkarte, vielleicht habe ich den falschen Empire-Efi-Iso, könnte mir vll jemand den richtigen raussuchen?


    LG, MM

    AntwortenLöschen
  19. Hallo,

    leider funktioniert es bei mir auch nicht.

    Lenovo T410i mit Windows 7 64Bit und Virtual Box 3.2.8

    Hat auch mit der Version 3.2.6 nicht funktioniert. Bei beiden Versionen bleibt die VM nach dem Wechsel auf die Mac DVD und dem kurzen Output (siehe Screen http://i37.tinypic.com/cjng2.jpg) stehen.

    Kann mir jemand einen Tipp geben?

    AntwortenLöschen
  20. Mit diesem Bootimage funktioniert es!
    http://adf.ly/52191/http://www.tonymacx86.com/Public/iBoot-Supported.zip

    AntwortenLöschen
  21. @Admin

    wenn ich mir Deinen Screenshot unter: http://i37.tinypic.com/cjng2.jpg ansehe, steht dort als letzer Eintrag ein "Press any key to continue". Das ist korrekt, hast Du hier schon mal mit der Maus auf die VM geklickt, und ein Enter auf der Tastatur abgesetzt, damit es im Bootvorgang "weitergeht." Hab das gerade bei mir auch gestartet, sieht absolut identisch bei mir aus.

    AntwortenLöschen
  22. Hallo, danke erstmal für das Tutorial. Bei mir hat alles bestens funktioniert. Ich habe einen Phenom II X6 mit 8GB Speicher und Windows 7 Professional 64Bit. Bis jetzt läuft alles stabil.Habe mir auch deine Angegebene und getestete Virtual Box runtergeladen. :) mit der neuern hatte es nicht geklappt. Nun meine Frage, mein Iphone wird nicht erkannt :( Virtuel Box wollte immer Treiber installieren und hat aber keine gefunden. Da hab ich es mal mit der Sache versucht.
    Hostsystem
    Gerätemanager | Ansicht | Ausgeblendete Geräte anzeigen
    Zum Baum "Nicht-PnP-Treiber" gehen und dort "VirtualBox USB Monitor Driver" deinstallieren. Soweit so gut und es ging dann ohne Probs. Ich bekomme aber nach wie vor mein Iphone in Itunes in der VBox nicht angezeigt. Hat jemand einen Tipp. Währe echt dankbar.

    AntwortenLöschen
  23. Hallo,

    vielen Dank für das Super Tutorial.

    Ich bleibe leider immer an einer Stelle hängen:

    http://i52.tinypic.com/2ldhdle.jpg

    Irgendeine Idee?

    Habe einen HP mit Intel Quad Core CPU & 4GB RAM mit Windows 7 64Bit.

    AntwortenLöschen
  24. Ich habe es genau, wie in der Anleitung gemacht, aber beim starten von os x kommt der Fehler: Ebios error! Könnte das daran liegen, dass ich os x 10.6.0 benutzte?

    AntwortenLöschen
  25. Hoi, habe versucht meine original MacBook Pro Mac OS X 10.6.3 mit der VBox 3.2.0 (extra die alte Version geladen) & EFI 1085 auf meinem Intel / Nvidia zu installieren. Geht alles bis zum Installation vorbereiten, danach kommt "Mac OS X kann auf diesem Computer nicht installiert werden"
    Habe schon neue VBox mit alter EFI, alte VBox mit iBoot... usw probiert - bin ratlos -j-

    AntwortenLöschen
  26. Hmm bzgl. "Mac OS X kann auf diesem Computer nicht installiert werden". Das ist eine interessante Meldung. Ich meinte mich zu erinnern dass Apple mit der OS X 10.6.2 alle "Atom"-User rausgeworfen hat, d.h. alle die z.B. einen kleinen Dell Mini 10v mit einer Atom-CPU und Mac OS X 10.6 hatten, wurden mit dem Update auf 10.6.2. höflich darauf hingewiesen, dass diese CPU nicht von Apple unterstützt wird.

    Könnte ich mir vorstellen, dass da bei 10.6.3. etwas in der Form für die Virtualisierung vorgesehen ist ?! Kann das jemand bestätigen oder wiederrufen ?

    AntwortenLöschen
  27. Interessante Hardcopy unter:
    http://i52.tinypic.com/2ldhdle.jpg

    Ich hab hier gerade nochmals mein Mac OS X in der Virtualbox angeworfen, aber diese "Boot-Meldungen" habe ich nicht. Ich denke mal die Kext Meldungen zeigen an, dass er eine KernelExtenstions nicht laden kann. Evtl. mal die ACPI Checkbox aktivieren.

    AntwortenLöschen
  28. Danke für den Hinweis dass das auch mit einer AMD Phenom II X6 funktioniert. Das hätte ich ehrlich gesagt nicht gedacht, da Apple (bis jetzt) ja keine AMD-CPUs offiziell verkauft. Das sieht für mich aber so aus, als ob es vielleicht in naher Zukunft auch möglich ist Orignal-Apple Hardware mit einer AMD-CPU zu bekommen.

    Sehr interssant :-)

    AntwortenLöschen
  29. zur Frage:
    wenn ich mir Deinen Screenshot unter: http://i37.tinypic.com/cjng2.jpg ansehe, steht dort als letzer Eintrag ein "Press any key to continue". Das ist korrekt, hast Du hier schon mal mit der Maus auf die VM geklickt, und ein Enter auf der Tastatur abgesetzt, damit es im Bootvorgang "weitergeht." Hab das gerade bei mir auch gestartet, sieht absolut identisch bei mir aus.


    Jas das geht, ich erhalte die Meldung "press an key". Wenn ich mit der Mouse auf die VM klicke "verschwindet" der Mauszeiger, d.h. der ist in der VM "gefangen", jedoch kann ich ohne Problem die Enter-Taste auf der Tastatur betätigen, und es geht im Boot-Vorgang weiter.

    AntwortenLöschen
  30. zur Hardware:

    "Intel Pentium 4 mit 3,20Ghz, der unterstützt nicht die Virtualisierungstechnologie aber Hyperthreading
    Außerdem brucht man die für Virtual Box mit OsX doch auch garnicht oder?
    Außerdem habe ich 2gb Ram und ne Ati Radeon Grafikkarte."

    würde ich sagen, ist zu alt, und leider viel zu lahm, um darauf die Vitualbox laufen zu lassen, geschweige denn OS X in der VM. Deine CPU war mal sehr gut, ist aber schon lange her. Einfach nen aktuellen PC von der Stange kaufen, dann hast ne vernünftige CPU und Leistung.

    AntwortenLöschen
  31. Danke für die tolle Anleitung. Hat super funktioniert!

    Virtualbox 3.2.8
    OS X 10.6.3 -> onlineupgrade auf 10.6.4

    AntwortenLöschen
  32. Hoi again, eben mit VMWare Player und 'nem experimentellen Image das gleiche Problem. "Mac OS X kann auf diesem Computer nicht installiert werden". Ich geb's auf mit der Büchse. Also falls jemand sonst 'nen Dell Inspiron 545: Core2Quad Q9400, Nvidia GeForce GT 220 zu laufen kriegt bin für jeden Hinweis dankbar. -j-

    AntwortenLöschen
  33. Tipp: Das mit den Abstürzen beim runterfahren und rebooten kommt von der facesmc. Die Installation dieser kext erspart man sich aber, wenn man folgende Command auf der Windows Kommandozeile absetzt (OSXVMName durch den echten Namen ersetzen):

    VBoxManage setextradata "OSXVMName" "VBoxInternal2/SmcDeviceKey" "ourhardworkbythesewordsguardedpleasedontsteal(c)AppleComputerInc"

    AntwortenLöschen
  34. Hallo. Ich habe dies auch versucht. Bin doch nur zu der Sprachauswahl gekommen. Danach kam eine Meldung das Mac OS X nicht auf diesem Computer installiert werden könne. Aber ich weiss nicht was ich falsch gemacht habe. Ich habe genau die Anleitung befolgt. HILFE!!!

    AntwortenLöschen
  35. Also bei mir mit meinem AMD-Rechner kommt am Ende der Installation die Fehlermeldung, dass auf diesem System die Installation nicht möglich ist. DIese Fehlermeldung könnt ihr ignorieren einfach EFI-Iso mounten und die VM zurücksetzen. Die Mac Festplatte lässt sich dann beim Booten auswählen und es läuft.
    Thx für das Tutorial dachte schon Als AMD-Nutzer käme ich da nie ran.

    AntwortenLöschen
  36. Das sollte auch mit einer anderen Wondows Version (XP) funktioniern, oder?

    AntwortenLöschen
  37. muss schon zugeben ... habe noch nie eine so genaue anleitung erhalten, wo alles beim ersten mal geklappt hat! einfach spitze!

    AntwortenLöschen
  38. Hab heute Probiert OS X 10.4.6 Tiger auf diese Art zu installieren und sobald er anfängt die Install ISO zu laden kommt die Windows Meldung: Das Programm funktioniert nicht mehr.

    Was kann ich da tun ?????

    Brauche dringend Hilfe. Bitte und Danke !

    ---------
    Hab nen HP Pavilion dv6
    Intel Core i5 M 430 @ 2.27 GHz
    4 GB Ram und Win 7 Home Premium 64-Bit.
    -- falls ihr diese Angaben braucht...

    AntwortenLöschen
  39. "Interessante Hardcopy unter:
    http://i52.tinypic.com/2ldhdle.jpg

    Ich hab hier gerade nochmals mein Mac OS X in der Virtualbox angeworfen, aber diese "Boot-Meldungen" habe ich nicht. Ich denke mal die Kext Meldungen zeigen an, dass er eine KernelExtenstions nicht laden kann. Evtl. mal die ACPI Checkbox aktivieren."

    Ich habe genau das selbe Problem!
    Wo aktiviere ich die ACPI Checkbox?

    AntwortenLöschen
  40. http://img190.imageshack.us/i/macfehler.jpg/

    hier nochmal das ist mein fehler! hoffentlich kann mir einer helfen, nutze einen dell xps m1330 centrino dualcore und win 7, 4GB Ram

    Gruß Daniel

    AntwortenLöschen
  41. WOW funktioniert super nur der Link zu empireEFIv1085.iso funktioniert nicht. Neuer Link:

    http://www.mediafire.com/?lnekzzyjcti


    Danke für das gute Tutorial

    AntwortenLöschen
  42. Ich hab hier nur eine 10.5.7 rumliegen. Geht es mit dieser auch?

    Und ich habe nur eine DVD. Geht es damit auch? Weil ich bekomme immer ein EBIOS read error.

    AntwortenLöschen
  43. Gute Anleitung!
    Ich hänge aber beim booten von dem Iso Image. Das Empire EFI läuft auch. Es steht dann nur "Press any key to continue..." Ab da geht es nicht mehr weiter. Kann mir jemand helfen? Oder liegt das an meinem AMD Phenom II X4 955 Prozesor?

    AntwortenLöschen
  44. Bei mir ist die Auflösung nur 1024x768 kann man das irrgendwie höherstellen
    sonst super Anleitung.

    AntwortenLöschen
  45. Ja bei mir ist es genau so wie bei Michael:
    http://media.orderingdisorder.com/2010/10/step13.jpg
    Ich weiß nicht weiter...

    AntwortenLöschen
  46. Ich hatte direkt nach der Installation auch das Problem mit dem Hängenbleiben beim Boot wie in http://i52.tinypic.com/2ldhdle.jpg gezeigt.

    Ich konnte mir folgendermaßen Abhilfe verschaffen:

    - ich habe alle weiteren Schritte (EFI Zeugs) ignoriert und direkt EFI wieder in der VM aktiviert
    - dazu habe ich diese (leicht magische) Einstellung von anonym oben durchgeführt
    VBoxManage setextradata "OSXVMName" "VBoxInternal2/SmcDeviceKey" "ourhardworkbythesewordsguardedpleasedontsteal(c)AppleComputerInc"
    - falls es von Belang sein sollte, ich habe noch 3D Beschleunigung deaktiviert und den Grafikspeicher auf 32 MB reduziert

    Danach lief alles wunderbar ohne weitere Einstellungen.

    Bin auf Kubuntu 10.10 mit Intel Core2 Duo CPU.

    AntwortenLöschen
  47. PS: Vielen Dank für die Anleitung :-)

    AntwortenLöschen
  48. Hallo, tolle Anleitung!
    Habe aber ein Problem NACH der Installation.
    Beim Neustart nach der Installation bleibt die VM bei folgendem Schritt hängen:
    http://i52.tinypic.com/in92r4.gif

    Habe auch schon 2x neugestartet, immer der gleiche Punkt wo er hängenbleibt.

    Jemand eine Idee was da schief läuft oder was ich probieren könnte?

    Vielen Dank,
    Chris

    AntwortenLöschen
  49. Vielen Dank für die Anleitung.

    Ich habe ein Dell XPS M1330 mit 4GB RAM und Windows 7 x64. Darauf das momentan aktuellste Virtualbox 3.2.12.

    Ich hatte es erst mit einer älteren Snow Leopard DVD (ich meine 10.4.2) versucht, aber das gab nur Fehlermeldungen, wie sie hier auch schon teilweise gepostet wurden. (Memory allocation error, boot block error, ACPI error)

    Dann habe ich mir ein ISO Abbild der Retail DVD mit Version 10.6.3 besorgt und mich streng an deine Anleitung gehalten und es funktionierte auf Anhieb.

    AntwortenLöschen
  50. habe auch das problem das ich danach ieine Taste drücken soll, aber nichts passiert. Der schritt mit der "magischen formel" hört sich ja nach der Lösung an, verstehe ihn nur nicht. Könnte mir das jmd step by step erklähren?

    AntwortenLöschen
  51. Ich glaube zwar nicht an die magische Formel und halt das eher für Verarsche, aber man müsste sie in einer DOS-Box / Eingabeaufforderung eingeben -> Start - Programme - Zubehör - Eingabeauffordrung und dann die gesamte "Formel" in einer Zeile eingeben und Enter drücken, wobei OSXVMName durch den Namen ersetzt werden müsste den die VM bei dir wirklich hat.

    AntwortenLöschen
  52. Verarsche hin oder her, bei mir war es notwendig ;-)

    AntwortenLöschen
  53. Nachtrag: Und zwar reproduzierbar notwendig, habe die Maschine mehrfach eingerichtet.

    AntwortenLöschen
  54. Tja, wenn man so drüber nachdenkt. Da hätte wahrscheinlich jeder Text funktioniert :-D

    AntwortenLöschen
  55. Ich konnte mein Problem ein bisschen lösen. Ich hab die DVD einfach auf Passthrough gestellt.
    Jetzt zeigt er mir aber auf der EFI-Seite nur "Mac OS X Install DVD" an und es geschieht nix.

    AntwortenLöschen
  56. Eine tolle Anleitung.. SUPER

    Leider kommt bei mir nach dem Wechsel auf die Installations DVD eine schwere Fehlermeldung und ich muss beenden. im Log kommt zum Schluss:
    Changing the VM state from 'DESTROYING' to 'TERMINATED'.
    Woran könnte dies liegen?

    AntwortenLöschen
  57. Hi,
    for me there was an easy was to change the screen resolution (can be found in VBox-Docu as well -> RTFM):
    --
    3.12.1 Video modes in EFI
    EFI provides two distinct video interfaces: GOP (Graphics Output Protocol) and UGA (Universal
    Graphics Adapter). Mac OS X uses GOP, while Linux tends to use UGA. VirtualBox provides a
    configuration option to control the framebuffer size for both interfaces.
    To control GOP, use the following VBoxManage command:
    VBoxManage setextradata "VM name" VBoxInternal2/EfiGopMode N
    Where N can be one of
    0,1,2,3,4 referring to the
    640x480, 800x600, 1024x768, 1280x1024,1440x900
    screen resolution respectively.
    To change the UGA resolution:
    VBoxManage setextradata "VM name" VBoxInternal2/UgaHorizontalResolution 1440
    VBoxManage setextradata "VM name" VBoxInternal2/UgaVerticalResolution 900
    The video mode for both GOP and UGA can only be changed when the VM is powered off and
    remains persistent until changed.
    --
    So for me this worked:
    VBoxManage setextradata "MAC OSX 10.6.3" VBoxInternal2/EfiGopMode 4

    Have fun.

    AntwortenLöschen
  58. bekomme auch beim Imgae-Wechsel zwischen EFI und Snow Leopard die "Memory Allocation Error" Meldung...

    Meine CPU: Intel Core 2 Duo T7700

    Jemand einen Tipp??

    AntwortenLöschen
  59. Hallo
    erstmal Lob an Autor super Tutorial.

    Meine Frage:
    Kann ich von Mac OS X 10.6.3 auf Mac OS 10.6.6 aktualisieren ohne das ich irgendetwas kaputt mache ???
    Weil ich möchte unbedingt den neuen Mac App-Store haben.

    Danke schon mal an alle die antworten

    Lg Jan

    AntwortenLöschen
  60. Danke für die Anleitung, alles funktionierte auf Anhieb, auch die Umstellung auf 1440x900. und zwar OS X 10.6.3 (Retail) unter Virtualbox 3.2.10 unter PinguyOS/Ubuntu 10.10 auf einem Q6600-8GB
    thx ..

    AntwortenLöschen
  61. Zu diesem Kommentar

    27. Juli 2010 20:49
    bei mir wehrt sich der installationsdialog von os x 10.6 und meint, das eine installation auf dem system nicht möglich sei...

    hab ich einen Hinweis:
    Diesen Effekt hatte ich, als ich versucht habe, SnowLeopard mit Hilfe einer DVD eines airbook auf einem iMac zu instalieren. Die airbook dvd scheint
    also einen Hardware Test zu machen.

    Da auf meinem iMac 10.5 stabil läuft, ich aber 10.6
    probieren wollte hab ich das auch in virtualbox gemacht. Es läuft, inkl. direkt efi boot.

    Danke schön!

    AntwortenLöschen
  62. Ah, hab noch was vergessen:

    zum Installieren der kExt benötigt der "kext helper b7" den root account, der aber nicht per default aktiviert ist.

    Das geht mit Hilfe des Programms Verzeichnisdienste, in SnowLeopard zu finden in Systemeinstellungen->Benutzer->AnmeldeOptionen

    AntwortenLöschen
  63. Hi!
    Ich habe Mac OSX 10.6.6 habe aber folgendes Problem. Wenn es alles Hochgeladen ist, kann ich weder Maus noch Tastatur benutzen. Woran kann das Liegen?? Währe für euer Rat sehr dankbar!
    Gruss

    AntwortenLöschen
  64. Hallo,

    das mit der Tastatus und Maus hatte ich auch.
    Wichtig ist, daß in der Virtual Box in System der Hacken "Absolutes Zeigergerät aktivieren" gesetzt ist. Danach hat es mit 10.6.3 super funktioniert.

    AntwortenLöschen
  65. Hallo ich habe eine frage verwendet ihr alle 3.2.0 von Virtualbox ? ist die neue 4.0.2 nicht zu gebrauchen ?

    gruss

    AntwortenLöschen
  66. Hallo,
    ja es funktioniert auch noch mit der aktuellsten Version von Virtual Box.

    Wenn jemand von euch einen i3, i5 oder i7 besitzt darf er nicht den Empire EFI benutzen sonder iBoot (einfach googeln).

    lg

    AntwortenLöschen
  67. HI,

    klasse, dann werde ich mal iBoot ausprobieren. Ich komme nur mit EFI bis zur Sprachauswahl und dann sagt er mir das es nicht möglich ist zu installieren. Kann das am EFI Boot liegen?


    Grüße....

    AntwortenLöschen
  68. So ich bin es wieder, also bei mir klappt das nicht es erscheint immer die Meldung: Das installieren von Mac OS auf diesen Computer ist nicht möglich.

    Warum?

    Ich habe es nach dieser Anleitung probiert.

    Ich habe:

    - EFI
    - iBoot
    - iBoot Legacy

    alles probiert, kein ERfolg!

    Ich habe einen i5 Prozessor falls das hilft.

    Kann mir noch jemand einen Tipp geben?

    DANKE!


    Gruß, David

    AntwortenLöschen
  69. Ich habe auch einen Core i5 und es geht weder mit empireEFI, noch mit iBoot... Nachdem ich die mac.iso ausgewählt habe und F5 drücken soll (was bei mir mit esc geht), kommt das hier: http://img827.imageshack.us/f/macb.png/

    Kann das auch daran liegen, dass ich Ubuntu 10.10 habe?

    AntwortenLöschen
  70. Gute Anleitung!
    Ich hänge auch beim booten von dem Iso Image. Das Empire EFI läuft auch. Es steht dann nur "Press any key to continue..." Ab da geht es nicht mehr weiter. Kann mir jemand helfen?

    Ich habe den Intel i3 370M mit 2,3 GHz, 4 Gb Ram und windows 7 64 Bit Home Premium. Diese Magische Eingabe habe ich auch schon Versucht, klappte aber nicht.

    AntwortenLöschen
  71. Ich habe grade des Rätsels Lösung gefunden.
    Einfach diese EFI runterladen.

    http://rapidshare.com/files/454225260/EmpireEFI-1063.zip

    AntwortenLöschen
  72. Klappt auch nicht =(
    Vllt. werden manche hier fündig:
    http://www.taranfx.com/install-snow-leopard-virtualbox

    AntwortenLöschen
  73. Leider nein, nichts zu machen. Ich weiß nicht warum aber ich bekomme immer die Meldung von MacOS nach dem ich die Sprache ausgewählt habe das das System auf diesen Computer nicht installiert werden kann.

    :-(

    AntwortenLöschen
  74. Kleiner Tipp: einfach mal den System-Typ auf BSD und FreeBSD umstellen. Dann klappt das Booten mit EFI und das Einstellen der größeren Auflösung (s.o.) ohne Probleme.
    Bei mir jedenfalls.

    AntwortenLöschen
  75. hallo
    bei mir funktioniert alles nur ich bekom das mit der Auflösung nicht hin kann mir da jemand helfen??
    bitte

    mfG

    AntwortenLöschen
  76. Bei mir Startet nicht einmal EFI, ich hab schon mehrere Efi Versionen ausprobiert, es funktioniert keine.
    Ich habe einen Intel i3 auf nem Acer Laptop.
    Bitte helft mir!

    AntwortenLöschen
  77. Ich habe das nach der Anleitung alles brav gemacht mit OSX 10.6.0 auf einem Core Duo (T2400) mit VirtualBox 4.0.8. Ich bin auch bis zum Festplattenprogramm und der Installtion gekommen, hat auch alles soweit geklappt, nur nach 20 Sekunden der Installation von OS X kommt: "Installtion fehlgeschlagen. Mac OS kann nicht auf diesem Computer installiert werden"

    AntwortenLöschen
  78. Superanleitung, OS X 10.6 läuft problemlos. Aber hat schon jemand das Update auf 10.6.6 oder höher geschafft? Nach einem Update auf 10.6.6 hängt sich die Box beim Starten häufig auf. In der Regel muß ich 4-5 mal starten, bevor sie komplett hochfährt.

    AntwortenLöschen
  79. Super Ableitung.

    Hab schon vor einigen Monaten versucht mir osx als VM auf meinem Windows 7 64Bit mit VM-Ware zu installieren doch das hat nie geklappt. Problem ist auch das ich nen AMD, ATI System habe.

    Bin denn durch Zufall auf dieses Tutorial gestossen und dankt der aktuellen Empire iso hat nun auch auf meinem AMD Phenom geklappt! Top.

    Hab nun das Problem das ich die Maschine nicht mehr nach dem update starten kann. Weiß nicht welche die momentane aktuelle Version ist :) außerdem funktioniert die Sache mit der Umgehung der Boot Disc nicht

    AntwortenLöschen
  80. nach der installation habe ich probleme...
    bei mir kommt diese fehlermeldung
    http://mychannel1.webatu.com/Unbenannt.png

    wenn ich mit der idee von daniel versuche:
    "Ich habe grade des Rätsels Lösung gefunden.
    Einfach diese EFI runterladen.

    http://rapidshare.com/files/454225260/EmpireEFI-1063.zip "

    bei anderen efi dateien bleibt nur ein eingefrorener screen

    AntwortenLöschen
  81. Moin,
    ich habe die Anleitung auf einem AMD und einem nagelneuen Intel i3 System probiert. Beides mal blieb ich direkt nach dem Einlegen der SnowLeopard-ISO hängen.
    Erst kamen ein paar Zeilen Code, dann irgendein Fehler, kann ACPI-Table nicht laden...dann Starte darwin x86 ...und danach war Ende. Stillstand. Habe noch einiges in den Einstellungen der VM probiert, aber immer das gleiche. Und wie gesagt, auf beiden Systemen das gleiche Ergebnis.
    Kennt jemand das Problem und hat es evtl. gelöst bekommen?

    AntwortenLöschen
  82. Hallo,
    die Installation hat wunderbar funktioniert, allerdings wollte ich jetzt auf Lion updaten, aber beim Update kommt die Fehlermeldung, dass Lion 2GB an Arbeitsspeicher braucht ... ich habe der virtuellen Maschine sogar 3GB zugewiesen, aber OS X erkennt nur 1GB ...
    Einen Rat?
    Vielen Dank

    AntwortenLöschen
  83. ich habe ein Problem Mac os x lion Virtuel zu installieren egal wie ich es drehe und versuche bekomme immer die selbe meldung. habe verschiedene win versionen verschiedene linux versionen ohne Probleme am laufen nur mac will nicht.

    Systeme:
    System: Windows 7 Ultimate
    V-System: Windows 8 Developer Preview
    V-System: Windows Vista Ultimate
    V-System: Windows XP Pro
    V-System: Debian 6.0.3
    V-System: Ubuntu 11.10
    V-System: KUbuntu 11.10
    V-System: OpenSUSE 11.4
    V-System: Mac OS X 10.7

    hardware:
    CPU Typ: HexaCore AMD Phenom II X6 Black Edition 1100T
    Motherboard: ASRock 880G Pro3
    Motherboard Chipsatz: AMD 880G, AMD K10
    Arbeitsspeicher: 16377 MB (DDR3-1333 DDR3 SDRAM) (Corsair Vengeance CMZ8GX3M2A1600C9)
    BIOS Typ: AMI (03/25/2011)
    Grafikkarte: ATI Radeon HD 5700 Series (1024 MB)
    Monitor: LG E2350 (HDMI) [23" LCD] (190116843009)
    Soundkarte: Realtek ALC892 @ ATI SB800 - High Definition Audio Controller
    Festplatte: Hitachi HDS721010CLA332 ATA Device (1000 GB, 7200 RPM, SATA-II)
    Festplatte: SAMSUNG HD103UJ ATA Device (1000 GB, 7200 RPM, SATA-II)
    Festplatte: SAMSUNG HD103SI ATA Device (1000 GB, 5400 RPM, SATA-II)
    Optisches Laufwerk: TSSTcorp DVD-ROM SH-D163A ATA Device (16x/48x DVD-ROM)
    DirectX: DirectX 11.0

    http://s1.directupload.net/images/111107/9tjspdq8.png

    AntwortenLöschen
  84. zur oberen frage glaube weiß nun warum ich den fehler bekomme. denke mal das die lion dvd nur das update ist -.-' benutze virtualbox 4.1.6 und habe nun versucht snow leopard zu installieren was ohne probleme funktioniert :)

    also falls jemand fragt: ja 1. funktioniert auch mit der neusten Vbox version. 2. Auch mit nem amd/ati system ;)

    AntwortenLöschen
  85. Vielen Dank für die Super Anleitung.

    AntwortenLöschen
  86. Ein wirklich sehr guter Guide ! Mal ein Tipp für alle AMD User, hier gibt es den EFI Bootloader für AMD Prozessoren, damit lief es bei mir einwandfrei :)

    http://download1983.mediafire.com/d6im0imra7kg/m5wzzwyfg4m/EmpireEFI4AMD.iso.zip

    AntwortenLöschen
  87. Gute Anleitung Danke
    Habe jetzt nur das Problem, dass nach dem Update von 10.6.3 auf 10.6.8 die Maus nicht anspricht.
    Arbeite mit der aktuellen Version von Oracle
    Danke für die Hilfe

    AntwortenLöschen
  88. Servus,
    habe ein kleines Problem mit der Mac OS X Installation. Nachdem OS X gebootet hat und ich die Sprache ausgewählt habe, kommt die Fehlermeldung "Mac OS X cannot be installed on this machine". Es wird ein Backup aus einer Time Machine oder ein Neustart angeboten.

    Meine PC-Konfig ist ein Lenovo R400 Notebook und Windows 7 64bit.

    Hat irgendeiner eine Idee?

    Danke und viele Grüße

    AntwortenLöschen
  89. Funktioniert alles super! Danke! Mein System:
    AMD Phenom II X6 T1090
    ATI Radeon 6850HD
    M4A89GTD Pro USB 3.0
    500 GB Sata 3.0 Festplatte

    Also das ist das einzige Tut was ich gefunden habe wo es mit AMD auch funktioniert! Wichtig ist halt nur jeden schritt zu folgen!

    AntwortenLöschen
  90. Dieser Kommentar wurde vom Autor entfernt.

    AntwortenLöschen
  91. Wie lange muss man den vor der Installation warten?

    AntwortenLöschen
  92. Das war echt super!

    Es hat mit geklappt, ich habe diese Tutorial mit Mac OS Leopard, aber irgendwie funktioniert es nicht mehr mit Lion?

    Trotdem danke

    Robert von laptopsreviewers.com

    AntwortenLöschen
  93. Hallo
    ich habe folgendes problem
    und zwar lade ich das empireefi
    und switche dann auf das mac osx 10.6.4 istallations image
    drücke dann enter
    dann möchte er das ich eine belibige taste drücke zum weitermachen
    soweit alles gut

    nur dann wird das bild schwarz und es passiert garnichts mehr

    hat jemand eine lösung?
    MfG

    AntwortenLöschen
  94. bei mir läuft alles tadel los nur er hängt immer bei ´´pci configuration begin´´ .. bitte um hilfe .. ich weiß net weiter

    AntwortenLöschen
  95. Ich kann die Auflösung nicht über 1024x768 stellen.

    AntwortenLöschen
  96. Etwas mehr als 20€... Auf Amazon kostet es 32,50€!

    AntwortenLöschen
  97. Hi, versuche verzweifelt unter WIN 8.1 MAC OS X 10.6.3 zu installieren es funkt nicht bin recht verzweifelt und hör erstmal auf. meldet loading darwin
    loading kernel mach_kernel
    can´t find mach_kernel
    davor kommmt im fenster o.li.
    darwin/x86 boot v5.0.132 - chameleon v2.0-RC3 r
    build date 2010-02-07 13:11:58
    2047 mb memory
    mit virtualbox4.3.15 versuch gestartet, das sieht alles etwas anders aus als in der Anleitung
    Hilfe würd mich freuen, danke vorab & grüße

    AntwortenLöschen